Get quick answers to all your questions
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Please see below a list of frequently asked questions in regard to room panels.
Q: What is a room panel?
This is an Android/iPad tablet which is installed outside of a meeting room. This can display information such as meeting room name, and room availability. It is also a touch screen, so it is interactive and therefore you will be able to book meetings, cancel meetings, and check into meetings via the panel.
Q: What hardware do we support?
We support Qbic and Logitech, iPad.
Q: What is an Android version?
Android versions (codenames) are used to describe the various updates for the open-source Android mobile operating system.
To find this information, please use your device guide.
Q: What is CollabOS?
Logitech has built its own firmware called CollabOS, based on Android 10, but it is locked down and provides best-in-class security, privacy, and performance. Several Logitech products have the CollabOS operating system, including Logitech Tap Scheduler.
Q: What is an APK file?
APK stands for Android Package (sometimes Android Package Kit or Android Application Package). It's the file format that Android uses to distribute and install apps. As a result, an APK contains all the elements that an app needs to install correctly on your device.
Q: How do room panels work with RICOH Spaces?
The room panels will work with RICOH Spaces via our own RICOH Spaces Smart Display App which would need to be installed on the panel. The app is then paired and synced with RICOH Spaces.
Q: What is KIOSK mode?
Kiosk mode does not allow end-users to access other apps on the device. They also cannot exit the RICOH Smart Displays app, making it a dedicated device for that specific app. To configure a KIOSK mode on QBIC devices, follow the following instructions:
Restart the panel
Once restarted press “Cancel Autoplay”
Select Settings
Select Player Settings
Fullscreen = Off
Q: Is there a dark mode for visitor panels?
Yes! Head to your panel settings and select Dark.
Q: How do our room panels receive data?
The room panel is connected to your RICOH Spaces instance once paired. This means your existing O365 integration / Google integration will be used to show meeting information on the screen. The display connects directly to the RICOH Spaces API to receive all data in real time without additional configuration.
Q: What troubleshooting steps can we perform before contacting the RICOH Spaces Team when a panel is offline?
Reboot the panel (Powering down then powering back up).
Check local power and try alternative power sources.
Try an alternative ethernet cable (If applicable).
Confirm if the panel is receiving power.
Confirm if there are any network issues or if there've been any recent network changes, whether this is via WiFi or directly via Ethernet cable.
Q: What are the 3 different types of screens you can integrate with the RICOH Spaces platform?
Head here.
Q: Can I purchase a panel from RICOH Spaces or can I source my own?
Head here.
Q: My panel is randomly restarting and/or losing connectivity?
Symptoms:
Panel randomly restarts
Panel randomly loses network connectivity
Possible cause:
Underpowered PoE connection
QBIC suggests PoE+ (25W)
Logitech suggests - Power over Ethernet (PoE), IEEE 802.3af Type 1, Class 3 device
Solution:
Customer to ensure PoE is able to provide enough power.
Swapping to a different network port (or preferably a different network switch).