FAQ - Smart Displays
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Written by Kiren Dosanjh-Dixon
Updated over a week ago

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Please see below a list of frequently asked questions in regard to room panels.

Q: What is a room panel?

This is an Android tablet which is installed outside of a meeting room. This can display information such as meeting room name, and room availability. It is also a touch screen, so it is interactive and therefore you will be able to book meetings, cancel meetings, and check into meetings via the panel.

Q: What hardware do we support?

We support Qbic and Logitech.

These are the recommended hardware that we supply for using RICOH Spaces.

Q: What is an Android version?

Android versions (codenames) are used to describe the various updates for the open-source Android mobile operating system.

Q: Are there minimum requirements for devices?

Yes. We have minimum requirements particularly because our dependencies (for example, MapsPeople or Microsoft InTune) require them. The device model will be dictated by the OS version compatibility.

The latest requirements for Smart Displays are iOS 14.0 and Android 8.0. For Apple devices that is iPad Air 2, iPad Air 3rd Generation, iPad 5th Generation and iPad Mini 4 and later. All iPad Pro models are supported.

The latest requirements for mobile are iOS 14.0 and Android 6. For Apple devices that is iPhone 6S and later.

Q: What is CollabOS?

Logitech has built its own firmware called CollabOS, based on Android 10, but it is locked down and provides best-in-class security, privacy, and performance. Several Logitech products have the CollabOS operating system, including Logitech Tap Scheduler.

Q: What is an APK file?

APK stands for Android Package (sometimes Android Package Kit or Android Application Package). It's the file format that Android uses to distribute and install apps. As a result, an APK contains all the elements that an app needs to install correctly on your device. RICOH Spaces regularly completes bug fixes, once they are tested and confirmed as working, they are then added to the latest APK file ready to be uploaded to the panels.

Q: How do room panels work with RICOH Spaces?

The room panels will work with RICOH Spaces via our own RICOH Spaces Smart Display App which would need to be installed on the panel. The app is then paired and synced with RICOH Spaces.

Q: What is KIOSK mode?

Kiosk mode does not allow end-users to access other apps on the device. They also cannot exit the RICOH Smart Displays app, making it a dedicated device for that specific app. This is typically configured by the IT admin and thus, can only be locked and unlocked by them.

Q: Is there a dark mode for visitor panels?

Yes! Head to your panel settings and select Dark.

Q: How do our room panels receive data?

The room panel is connected to your RICOH Spaces instance once paired. This means your existing O365 integration / Google integration will be used to show meeting information on the screen. The display connects directly to the RICOH Spaces API to receive all data in real time without additional configuration.

Q: What troubleshooting steps can we perform before contacting the RICOH Spaces Team when a panel is offline?

  • Reboot the panel (Powering down then powering back up).

  • Check local power and try alternative power sources.

  • Try an alternative ethernet cable (If applicable).

  • Confirm if the panel is receiving power.

  • Confirm if there are any network issues or if they've been any recent network changes, whether this is via WiFi or directly via Ethernet cable.

Q: What are the 3 different types of screens you can integrate with RICOH Spaces platform?

  • Room panel – Installed outside of a meeting room, provides information such as room availability and enables room booking, cancelling & check-in/out of meetings.

  • Visitor panel - Interactive screens for you and your visitors to use. It allows an easy sign-in and registration process.

  • Wayfinder panel - Wayfinding screens display your office floor map to find and book rooms based on office floors. It's a different way to present and interact with the Floorplan.

Q: Can I purchase a panel from RICOH Spaces or can I source my own?

You can do both. You can purchase one of our panels (QBIC or Logitech Tap Scheduler). This will come built-in with our RICOH Smart Displays application and you have the option for a managed service.

Alternatively, you can source your own hardware. All the requirements are that it is an Android-supported device. You can then install our RICOH Smart Displays app to configure your panels.

Q: How can I book a meeting room using the room panel?

As the room panel is interactive, you can book the meeting room by selecting a start time and end time. In order to confirm your booking, you might be prompted to type in your Pin Code or scan a QR Code.

Q: Why has my booking been cancelled?

There are multiple explanations for a meeting book to be cancelled.

This could be because you haven’t checked in to your meeting on time (this can be done via the panel); therefore your booking was automatically cancelled.

You left the meeting room for too long and thus the policy in place has automatically cancelled your booking.

Or one of the admins cancelled your booking, if this is the case then you would have received communication regarding this via email explaining this further.

Q: My meeting has ended earlier than expected, how do I release the booking via the room panel?

On the room panel, if you click on your existing meeting and then select the option “End now”, this will end the meeting and the room will then be available.

Q: How do I set up the parameters for my Visitor Panel?

You will need to set this up via the RICOH Spaces application, once this has been updated and saved it will then synchronize with the panel.

Some example fields that can be set up are the following:

  • Company name – Requires the user to fill in the details of the Company they are from.

  • Host – Requires the user to fill in the person they are visiting.

  • Vehicle registration – The user's vehicle registration number.

  • Job title – User’s job title.

Q: Can I book a meeting room via a Wayfinder panel?

You will be able to when Wayfinding is officially launched, but for now please use the RICOH Spaces web app or mobile app to make a booking.

Q: My panel is randomly restarting and/or losing connectivity?

Symptoms:

1) Panel randomly restarts

2) Panel randomly loses network connectivity

Possible cause:

Underpowered PoE connection

  • QBIC suggests PoE+ (25W)

  • Logitech suggests - Power over Ethernet (PoE), IEEE 802.3af Type 1, Class 3 device

Solution:

  • Customer to ensure PoE is able to provide enough power.

  • Swapping to a different network port (or preferably a different network switch).

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